vCloud Director Container Service Extension 2.6.x is here!

As more and more of our Cloud Providers are being asked to support providing K8s and Container services to their customers in a self-service and Multi-tenant fashion, we have released Container Service Extension over 30 months ago.

The goal of Container Service Extension was to offer an Open Source plugin for vCloud Director that gives our Cloud Providers the capabilities to spin and scale Kubernetes Cluster with ease and minimum knowledge of Kubernetes by the Infrastructure team. It is an easy service that our Cloud Providers can add to their catalog at no extra cost specific to CSE. For more information about CSE, I would suggest you take a look at: https://vmware.github.io/container-service-extension/INTRO.html

VMware Container Service Extension

Our Container Service Extension had been evolving quickly and we just released CSE 2.6 . CSE 2.6 beta has been in testing for sometime by several partners. In this release, we had a lot of great enhancements coming including a native UI.

Here is a summary of features included with Container Service Extension 2.6:

  • New Templates with updated Kubernetes and Weave
  • In place Kubernetes upgrade for clusters
    • CSE offers the new capability to do in place upgrade of Kubernetes related software in Native clusters. More details here. This had been requested for sometime, as partners loved the ease it provided to deploy K8s clusters and now they wanted to replicate that for upgrading K8s clusters. It is on it is way to CSE.
  • Secure Configuration files
    • CSE now supports encrypted configuration files. More details here.
  • CSE UI Plugin for vCD
    • CSE used to be mainly CLI based, where UI was possible through vRO or third-party. We are now adding it natively to CSE. Read more about it here
    • Here is some screenshots of the new CSE UI!!!!
    • CSE 2.6 Create K8s Cluster
    • CSE 2.6 Kubernetes Container Clusters List
  • Interoperability with vCD 10.1.0

Update: CSE 2.6.1 has included Support for Enterprise PKS 1.7 (and NSX-T 2.5.1)

Speak Your Mind

*