SRM Time Out (300 seconds) while waiting for SRA to complete discoverDevice Command

While setting up vCenter Site Recovery Manager 5.0.3 with NetAPP storage,  & in particular at the stage where I try to enable the array pair I was welcomed with the following error:

SRM Time Out (300 seconds) while waiting for SRA to complete ‘discoverDevice’ Command.

 SRM Time out while waiting for SRA to complete discoverdevice command

 

This SRM SRA Adapter error is not limited to NetApp storage, but a similar error can be seen with EMC & other vendors storage. If your storage is pretty busy or you have too many devices on it, the operation just can not get completed within the 300 Second (5 minutes) time out set by default in SRM. The solution for this problem is really simple, all you have to do is to increase the storage.commandTimeout . In my case, I just increased it to 1200 second (20 minutes) which should be more than sufficient for most environments.  Further, it is important to mention that this time out setting is setup per site, & must be repeated for both sites involved in your SRM setup. Below is the exact instruction:

1. Click Sites in the left pane, right-click your primary site, and click Advanced Settings.

2. In the navigation pane of the Advanced Settings window, click Storage.

3. Modify the storage settings as required.

4. To change SRA update timeout, enter a new value in the storage.commandTimeout field greater than its current value (the one I used was 1200 (20 minutes)).

5- Repeat step 1-4 for the secondary site.

6- Try to enable your array pair again.

This should resolve the time out error. Hope this help!

Comments

  1. Thanks for this. It worked as described.

Trackbacks

  1. […] enable the array pair and after I fixed the timeout error I have documented in the following post: SRM Time Out (300 seconds) while waiting for SRA to complete discoverDevice Command, I have faced this […]

Speak Your Mind

*

Sponsors